Solved: Composer detected issues in your platform

Your Composer dependencies require a PHP version

WordPress site is down? Let’s find how to solve this issue.

If you got the following message: “Your Composer dependencies require a PHP version

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 7.0.33. Your Composer dependencies require the following PHP extensions to be installed: bcmath

or a similar message to the one above:

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 5.6.40.

From this message we understand that your PHP version is not corresponding with the minimum requirements of your actual plugin version. So, you need to upgrade your PHP version from your cPanel. The 7.2.0 is not the newest version of PHP. The last PHP version (PHP 8) were launched few days ago, on 26th November, 2020.

Transfer WordPress Site for only $30 (limited offer!). Grab the offer: WordPress Transfer

Is PHP 7.0 still supported?

No. PHP 7.0 is not supported anymore. In fact, if your cPanel have one of these old PHP versions (PHP 5.6, 7.0, 7.1, and 7.2), you should update them immediately. These versions are marked as “End of life”, meaning that these versions are no longer security supported and could be exposed to unpatched security vulnerabilities.

You can find on Google a lot of resources regarding the old versions of the PHP. Just type “PHP 7.0.33 vulnerabilities” or “PHP 7.0.33 exploit db” and you will find a lot of answers.

Golden tip: If you have the opportunity to upgrade to PHP 8, don’t do it until February or March, 2021. You should wait for a stable version of the WordPress CMS, theme and plugins.

What is PHP 8.0?

According to php.net, PHP 8.0 is a major update of the PHP language.
It contains many new features and optimizations including named arguments, union types, attributes, constructor property promotion, match expression, nullsafe operator, JIT, and improvements in the type system, error handling, and consistency.

In order to solve this, do the following steps:

1. Do a backup of your website. Seriously!
2. Go to cPanel -> Select PHP Version -> Current PHP version ( change to PHP 7.4 ).
3. Clean your browser’s cache and try to access it.

In 2021, many hosting services already provide PHP 8.0.0. As I told you, I prefer a stable version, so the PHP 7.4 seems to be the perfect candidate this year. Of course, like any other enthusiast, I tested the PHP 8.0.0 on a few WordPress development projects, and I haven’t any problem resulted from the tests. But I recommend you to wait another few months before updating to the last PHP version, because everything will be stable in the short future.

If you have troubles, contact me.

Let me know if it works.

All the best!

Tags: , , ,
Menu