Opgelost: Composer heeft problemen gedetecteerd in uw platform

Uw Composer afhankelijkheden vereisen een PHP versie

WordPress site is down? Laten we eens kijken hoe we dit probleem kunnen oplossen.

Als u het volgende bericht krijgt:“Uw Composer afhankelijkheden vereisen een PHP versie

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 7.0.33. Your Composer dependencies require the following PHP extensions to be installed: bcmath

of een soortgelijk bericht als hierboven:

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 5.6.40.

Uit dit bericht begrijpen we dat uw PHP versie niet overeenkomt met de minimum vereisten van uw huidige plugin versie. Dus, je moet je PHP versie upgraden vanuit je cPanel. De 7.2.0 is niet de nieuwste versie van PHP. De laatste PHP-versie (PHP 8) werd enkele dagen geleden gelanceerd, op 26 november 2020.


WordPress Website Overdracht


 

Wordt PHP 7.0 nog steeds ondersteund?

Nee. PHP 7.0 wordt niet meer ondersteund. In feite, als uw cPanel een van deze oude PHP versies heeft (PHP 5.6, 7.0, 7.1, en 7.2), zou u deze onmiddellijk moeten updaten. Deze versies zijn gemarkeerd als “End of life”, wat betekent dat deze versies niet langer beveiligingsondersteund worden en blootgesteld kunnen zijn aan niet-gepatchte beveiligingslekken.

Op Google zijn veel bronnen te vinden over de oude versies van PHP. Typ gewoon “PHP 7.0.33 vulnerabilities” of “PHP 7.0.33 exploit db” in en u zult een heleboel antwoorden vinden.

Gouden tip: Als u de kans hebt om te upgraden naar PHP 8, doe het dan niet voor februari of maart 2021. U moet wachten op een stabiele versie van het WordPress CMS, thema en plugins.

Wat is PHP 8.0?

Volgens php.net is PHP 8.0 een belangrijke update van de PHP-taal.
Het bevat veel nieuwe mogelijkheden en optimalisaties, waaronder named arguments, union types, attributen, constructor property promotie, match expression, nullsafe operator, JIT, en verbeteringen in het type systeem, foutafhandeling, en consistentie.

Om dit op te lossen, doe de volgende stappen:

1. Maak een back-up van uw website. Serieus!
2. Ga naar cPanel -> Selecteer PHP Versie -> Huidige PHP versie ( wijzig naar PHP 7.4 ).
3. Maak de cache van uw browser leeg en probeer het te openen.

In 2021 bieden veel hostingdiensten al PHP 8.0.0 aan. Zoals ik al zei, geef ik de voorkeur aan een stabiele versie, dus de PHP 7.4 lijkt de perfecte kandidaat dit jaar. Natuurlijk heb ik, net als iedere andere enthousiasteling, PHP 8.0.0 getest op een paar WordPress ontwikkelingsprojecten, en ik heb geen enkel probleem uit de tests gehaald. Maar ik raad u aan nog een paar maanden te wachten met het updaten naar de laatste PHP-versie, omdat alles in de nabije toekomst stabiel zal zijn.

Als je problemen hebt, neem dan contact met me op.

Laat me weten of het werkt.

Het allerbeste!

Vorig bericht
[SOLVED] We zijn uw FAQ probleem aan het valideren voor de site
Volgend bericht
8 must-have WordPress plugins en functies in 2021
Menu